Druckansicht WP Residence

Ansicht von 7 Beiträgen - 1 bis 7 (von insgesamt 7)
  • Autor
    Beiträge
  • #14258
    Jens Schilling
    Teilnehmer

    In der Druckansicht von WP Residence werden die immonex Widgets nicht angezeigt.
    Ich weiß es gibt bereits einen Beitrag in diesem Forum dazu, aber dieser ist leider nicht ausreichend dokumentiert, um mir zu helfen.

    In der Datei plugins\wpresidence_core\misc\plugin_help_functions.php wird das Druckdesign erstellt:

    in $page_object->post_content sind die Beschreibungsstexte und Shortcodes enthalten. Nach dem apply_filters bleibt jedoch nur der Beschreibungstext stehen.
    Gibt es einen Trick oder eine Idee, wie der Widgetshortcode ausgeführt und in $content erhalten bleibt?

    Beste Grüße – Jens

    #14259
    Carsten Scheuer
    Keymaster

    Hallo Jens,

    das Problem ist in diesem Fall die die Angabe in der Zeile direkt unter dem von dir genannten Codeblock der Funktion wpestate_ajax_create_print:

    $content = do_shortcode( $content );

    Hiermit werden nämlich vor der Ausgabe explizit alle Shortcodes ausgefiltert, anstatt diese durch die entsprechenden Elemente zu ersetzen.

    Da die besagte Funktion im WP-Residence-Core-Plugin enthalten ist, kann sie leider nicht einfach im Child-Theme überschrieben werden. Mir fällt daher spontan nur die Lösung ein, hierfür ein extra Plugin zu erstellen, dass nur eine functions.php mit einer Kopie der o. g. Funktion enthält, bei der der do_shortcode-Befehl entfernt wurde. Dieses Plugin muss dann vor dem WP-Residence-Core-Plugin geladen werden.

    #14265
    Jens Schilling
    Teilnehmer

    So was hatte ich mir schon gedacht und auch ausprobiert. Leider funktioniert das jedoch nicht.

    Ein print_r($context) zeigt einfach nur den $context an, ohne die Shortcodes. Die wurden also mit do_shortcode($content) auch einfach nur entfernt.

    Kann es sein, dass das Widget hier nicht im richtigen Kontext aufgerufen wird?
    Welche Variablen oder Parameter müsste man denn bereit stellen?

    #14266
    Carsten Scheuer
    Keymaster

    In einer unserer WP-Residence-Entwicklungs-Installationen funktioniert’s ohne weitere Anpassungen, wenn in der betr. Funktion des Themes einfach der do_shortcode-Aufruf auskommentiert wird:

    // $content = do_shortcode( $content );

    Bitte auch einmal auf diese Art testen. Wenn’s so passt, muss eigentlich auch die Variante mit der angepassten Funktion per Plugin funktionieren.

    #14273
    Jens Schilling
    Teilnehmer

    Hallo Carsten,
    ich habe jetzt das Theme auf die aktuelle Version geupdatet, was erst mal leider nichts gebracht hat. Meine Tests nach deinen Vorschlägen durchgeführt waren leider auch nicht erfolgreich. Ich habe mir jetzt den $content nach jeder Codezeile ausgeben lassen:

    $content = $page_object->post_content;
    Test
    [immonex_widget name=“immonex_User_Defined_Properties_Widget“ title=“Preisangaben“ display_mode=“include“ display_groups=“prices“]
    [immonex_widget name=“immonex_User_Defined_Properties_Widget“ title=“Energieeffizienz“ display_mode=“include“ display_groups=“epass“]
    $content = apply_filters('the_content',$content);
    Test
    $content = do_shortcode( $content );
    Test

    Ich komme hier einfach nicht weiter. Gibt es noch ein paar Ideen, bitte?

    #14274
    Carsten Scheuer
    Keymaster

    Hallo Jens,

    zunächst mal muss ich mich korrigieren: Mein o. g. Lösungsansatz kann so gar nicht funktionieren – ich hatte beim Testen die Druckansicht einfach aktualisiert und dabei übersehen, dass in diesem Fall der reguläre Seiteninhalt angezeigt wird. SORRY!

    Mit der (noch) aktuellen Release-Version von OpenImmo2WP kann die Problematik nicht ohne größeren Aufwand umgangen werden, deswegen sende ich dir gleich die aktuelle Beta-Version per Mail (kann bereits produktiv eingesetzt werden). Ist diese installiert, muss nur noch folgende Filterfunktion in der functions.php des Child-Themes ergänzt werden. Anschließend wird die Ausgabe der immonex-Widgets auch gerendert.

    #14275
    Jens Schilling
    Teilnehmer

    Super! Das hat hervorragend funktioniert. Herzlichen Dank für den tollen Support!

Ansicht von 7 Beiträgen - 1 bis 7 (von insgesamt 7)
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.