Google Maps Autocomplete / Autovervollständigung funktioniert nicht

WordPress-Plugins für Immobilien-Websites Foren immonex Lead Generator Google Maps Autocomplete / Autovervollständigung funktioniert nicht

8 Beiträge anzeigen - 1 bis 8 (von insgesamt 8)
  • Autor
    Beiträge
  • #19188
    Thorsten
    Teilnehmer

    Guten Tag Support, Herr Scheuer,

    wir möchten den Immonex Lead Generator auf unserer neuen Website verwenden:
    WordPress: 6.0.1
    PHP: 7.4.29
    Immonex Lead Generator: 2.3.1

    Die Integration via der erforderlichen Google APIs & per Shortcode funktionierte ohne großen Aufwand.
    Nach Eintragung des Google API Keys verschwand das Eingabefeld unter dem Punkt „Standort“ und die Google Maps Karte inkl. der hinterlegten Koordinaten wird korrekt angezeigt.

    Das Problem jedoch besteht darin, dass die Autovervollständigung bis dato nicht funktioniert.
    Das Eingabefeld erscheint oberhalb der Karte, bei Eingabe eines Begriffs passiert jedoch nichts.

    Die Website befindet sich kurz vor der Veröffentlichung, weshalb der Wartungsmodus eingeschaltet ist.
    Nachfolende APIs sind aktiv:

    Geocoding
    Geolocation
    Maps Embed
    Maps JavaScript
    Maps Static
    Places

    Auf der Website laufen nebst Elementor keine weiteren Plugins.

    Haben Sie eine Idee?

    Vielen Dank für Ihre Unterstützung,
    T. H.

    #19189
    Carsten Scheuer
    Verwalter

    Hallo,

    wird eventuell ein JavaScript-Fehler in der Browser/Entwickler-Konsole angezeigt, wenn die betr. Seite bzw. das Karten-Formularelement angezeigt wird?

    #19190
    Thorsten
    Teilnehmer

    Ja, nachfolgende Fehlermeldung gibt der Browser beim Aufruf der Funktion aus:
    Uncaught (in promise) TypeError: Cannot read properties of undefined (reading ‚Autocomplete‘) at 701.js:1:173858

    Inhalt der Zeile 701:
    (self.webpackChunkimmonexLeadGen=self.webpackChunkimmonexLeadGen||[]).push([[701], […] tbc

    #19192
    Carsten Scheuer
    Verwalter

    Anscheinend ist die Google Places API hier noch nicht verfügbar.

    Wurde eventuell die Option Google Maps API laden unter Immobilien-Leads → Einstellungen → Google Maps deaktiviert, weil diese APIs anderweitig eingebunden werden?

    #19193
    Thorsten
    Teilnehmer

    Guten Morgen Herr Scheuer,
    danke für die schnelle Unterstützung.

    Die Vermutung hatte ich zunächst auch und habe den API Key sicherheitshalber aus den Elementor Einstellungen entfernt.

    Folgende Varianten habe ich getestet, um das Problem einzugrenzen:
    1. API Key nur innerhalb von Elementor eingetragen, keine Einstellungen in Immonex: Maps im Generator lädt nicht -> Formularfelder werden angezeigt.
    2. API Key in Elementor UND Immonex eingetragen: Maps im Generator lädt und Koordinaten werden angezeigt -> Autocomplete funktioniert nicht.
    3. API Key in Elementor UND Immonex eingetragen, Häkchen bei „Google Maps API laden“ entfernt: Maps im Generator lädt nicht -> Formularfelder werden angezeigt.
    4. API Key nur innerhalb von Immonex eingetragen, keine Einstellungen in Elementor: Maps im Generator lädt und Koordinaten werden angezeigt -> Autocomplete funktioniert nicht.

    Hinweis zu den API-Einstellungen bei Google:
    Dort ist Anwendungseinschränkungen –> HTTP-Verweis-URLs (Websites) und dort die Domain-URL mit Wildcard („*“) Deklaration konfiguriert.
    Die Beschränkung habe ich testweise aufgehoben, leider ohne Erfolg.

    Dokumentation:
    1. Das Plugin nutzt die Google Maps JavaScript API sowie die Google Places API für die Auto-Vervollständigung von Standortdaten etc. Für die reguläre Nutzung dieser Dienste muss nachfolgend ein individueller API-Schlüssel (hier anfordern) hinterlegt werden. –> erledigt.

    2. WICHTIG! Bitte zur Aktivierung des Places API Web Service für den hier genutzten API-Schlüssel auch den Anweisungen im Absatz „Erste Schritte“ von Googles Autocomplete-Infoseite folgen, andernfalls wird die Adress-Autovervollständigung womöglich nicht funktionieren. (Ein hervorragendes Tutorial zur Erstellung eines API-Keys dieser Art ist auch im kulturbanause Blog verfügbar.) –> Muss der Punkt „Loading the Library“ unter „Getting Started“ in der Places Autocomplete Dokumentation von Google ebenfalls berücksichtigt werden?

    3. ACHTUNG! Wird kein API Key eingetragen oder verfügt dieser nicht über die passenden Freigaben, wird in den Frontend-Lead-Formularen anstatt der kartenbasierten Standortauswahl ein Eingabeformular für die Objektadresse angezeigt. –> Karte wird korrekt angezeigt.

    4. Zudem sollten die für die Karte der Standortauswahl verwendeten Standard-Längen- und Breitengrade angegeben werden. Das können bspw. die Koordinaten des Zentrum des eigenen Einsatzbereichs oder des Maklerbüros sein. (Ermittelt werden können diese bspw. via Nominatim oder einen vergleichbaren Dienst.) –> Koordinaten passen.

    5. Die Einbindung der Google Maps API kann hier auch deaktiviert werden, sofern die Google Maps API inkl. der Places-Library anderweitig eingebunden wird (bspw. vom Theme oder einem anderen Plugin). –> Sicherheitshalber ist der API Key aktuell nur in Immonex hinterlegt.

    #19196
    Carsten Scheuer
    Verwalter

    Der API-Key bzw. die zugehörigen Berechtigungen können als Ursache ausgeschlossen werden, ansonsten würde eine andere Fehlermeldung angezeigt werden. Auch eine parallele Einbindung/Aktivierung der API via Elementor ist als Problemquelle eher unwahrscheinlich – wir konnten den Fehler auf diese Art bis jetzt zumindest nicht reproduzieren. (Eine Möglichkeit wäre noch, dass ein anderes Plugin ebenfalls die Maps-API – allerdings ohne Places-API – einbindet und so ein vollständiges Laden blockiert.)

    Im nächsten Schritt könnte einmal testweise die vorhandene durch die aktuelle Beta-Version des Plugins von immonex.dev ersetzt werden. Sollte das Problem hier weiterhin auftreten, müssten wir uns die Sache einmal „live“ ansehen: Es wäre prima, wenn Sie uns hierfür einen temporäres WP-Admin-Benutzerkonto mit der Mailadresse pluginsupport@inveris.de anlegen würden.

    #19199
    Thorsten
    Teilnehmer

    Hallo Herr Schreuer,
    dank Ihrer Hilfe konnte ich das Problem lösen.

    Ursache & Lösung:
    Ursache war ein Design-Plugin für Elementor (Premium Addons), welches selbst die Möglichkeit einer Google Maps Integration anbietet.
    Ich ahnte, dass dies zu einer Inkompatibilität führen könnte, weshalb ich an dieser Stelle bewusst keinen API Key eingetragen habe.

    Scheinbar scheint das Plugin aber trotzdem in Richtung Google kommuniziert zu haben denn…
    … die Lösung: Erst nachdem ich das Premium Addons Plugin eigene „Google Maps“ Widget explizit deaktiviert habe, funktioniert der API Zugriff per Immonex.
    Dort ist der API Key nun hinterlegt.

    Frage an Sie: Funktioniert Immonex mit der Google Maps API per Elementor (Pro)?
    Testweise habe ich den API-Schlüssel aus Immonex entfernt bzw. dort deaktiviert und in Elementor hinterlegt, wobei ab dem Moment wieder die Formularvariante unter „Standort“ in Immonex erscheint.
    Den API-Schlüssel per Elementor anzubinden wäre jedoch insofern charmanter, als dass ich Google Maps unabhängig von Immonex per Widget im Kontaktbereich der Website nutzen möchten.

    Vielen Dank für Ihre Unterstützung.

    #19207
    Carsten Scheuer
    Verwalter

    Die parallele Nutzung des Google-Maps-Widgets von Premium Addons for Elementor (nicht zu verwechseln mit Elementor Pro) ist folgendermaßen ab der Plugin-Version 2.4.8-beta (immonex.dev) möglich:

    1. Option Google Maps API laden unter Einstellungen → Immobilien-Leads → Google Maps deaktivieren
    2. Option Lade die Maps API JS-Datei unter Premium Addons for Elementor → Integrations deaktivieren
    3. Google Maps API mit der folgenden Hook-Funktion via functions.php des Child-Themes oder Code-Snippets-Plugin einbinden
8 Beiträge anzeigen - 1 bis 8 (von insgesamt 8)
  • Du musst angemeldet sein, um zu diesem Thema eine Antwort verfassen zu können.