Import funktioniert nicht

10 Beiträge anzeigen - 1 bis 10 (von insgesamt 10)
  • Autor
    Beiträge
  • #3527
    Willy Braun
    Teilnehmer

    Erstmal meine technischen Daten:
    Wordpress 4.3.1 mit Theme Realia.
    immonex OpenImmo2WP Version 1.7.
    PHP Version 5.5.30

    Ihr Plugin hab ich auf Realia Theme eingestellt.
    Ich hab bei Ammon einen Export der Zip konfiguriert.
    Der Import erzeugt keine neuen Daten.
    Hier ein Auszug des Logs:
    2015-11-05 00:43:49 [DEBUG] Plugin-Version: 1.7
    2015-11-05 00:43:49 [DEBUG] Importverzeichnis: /homepages/36/d578175001/htdocs/backends/immobilienpartner-pb/wp-content/uploads/immonex-openimmo-import
    2015-11-05 00:43:49 [DEBUG] Archivverzeichnis: /homepages/36/d578175001/htdocs/backends/immobilienpartner-pb/wp-content/uploads/immonex-openimmo-import/archive
    2015-11-05 00:43:49 [INFO] Entpacke 20151103_1248_openimmo_120151103_121535_260.zip
    2015-11-05 00:43:49 [DEBUG] Erfolgreich entpackt: 20151103_1248_openimmo_120151103_121535_260.zip
    2015-11-05 00:43:49 [DEBUG] Max. Script-Ausführungszeit: 30 s
    2015-11-05 00:43:49 [DEBUG] Max. Script-Speicherverbrauch: 122880 kb
    2015-11-05 00:43:49 [DEBUG] Max. Anzahl Datensätze pro Scriptlauf: unbegrenzt
    2015-11-05 00:43:49 [DEBUG] Max. Anzahl zu löschender Datensätze pro Scriptlauf: unbegrenzt
    2015-11-05 00:43:49 [DEBUG] Max. Anzahl Dateianhänge pro Scriptlauf: unbegrenzt
    2015-11-05 00:43:49 [DEBUG] 1 XML-Dateien im Archiv
    2015-11-05 00:43:49 [INFO] XML-Datei wird verarbeitet: data_20151103_121535.xml
    2015-11-05 00:43:49 [DEBUG] Immobilien in dieser Datei: 1
    2015-11-05 00:43:49 [INFO] Umfang: Teilimport
    2015-11-05 00:43:49 [INFO] Anbieter: XXXXX
    2015-11-05 00:43:49 [INFO] OpenImmo ANID: 110000

    2015-11-05 00:43:49 [INFO] Immobilie 1 von 1: Wohnen über den Dächern von XXXXX..
    2015-11-05 00:43:49 [DEBUG] OpenImmo OBID: MOA001-38461100003535
    2015-11-05 00:43:49 [INFO] Aktion: Löschen
    2015-11-05 00:43:49 [DEBUG] Immobilie nicht anhand OpenImmo-OBID gefunden: MOA001-38461100003535

    2015-11-05 00:43:49 [DEBUG] Extraktionsverzeichnis erfolgreich gelöscht: /homepages/36/d578175001/htdocs/backends/immobilienpartner-pb/wp-content/uploads/immonex-openimmo-import/20151103_1248_openimmo_120151103_121535_260
    2015-11-05 00:43:49 [INFO] ZIP-Archiv ins Archivverzeichnis verschoben: 20151105_0043_openimmo_120151103_121535_260.zip
    2015-11-05 00:43:49 [DEBUG] Import-Statusdatei gelöscht: current

    Muss ich noch was in WordPress an Realia konfigurieren?
    Was heisst Immobilie nicht anhand OpenImmo-OBID gefunden?

    Freundliche Grüße,
    Willy

    #3529
    Carsten Scheuer
    Verwalter

    Servus,

    laut Protokoll ist in der betr. Import-Datei nur ein Objekt vorhanden, das gelöscht werden soll („Aktion: Löschen“), deswegen wird es nicht importiert. Das Objekt konnte nicht anhand der OpenImmo-OBID gefunden werden, da es vorher noch nicht importiert wurde.

    Eine kurze Rückfrage zum Theme: Welche Realia-Version ist im Einsatz? (Das Plugin unterstützt aktuell nur Realia bis Version 3.x, Tests/Anpassungen für 4.x sind noch in Vorbereitung.)

    #3552
    Willy Braun
    Teilnehmer

    Hallo Herr Scheuer,
    ja war wohl das falsche Beispiel.
    Realia ist in der Version 3.2.3 installiert.

    Immer wenn ich den manuellen Import ausführe kommt eine MessageBox mit „Schwerwiegender Fehler während des Importvorgangs“.
    Das ist z.B. eine Log, wo was angelegt werden sollte. Die Immobilie wird auch angelegt, aber anscheinend fehlen da die zusätzlichen Bilder und PDF Dateien.
    Der Importer bleibt da auch stehen und nach ein paar Minuten kann ich auf Import fortsetzen klicken, aber da kommt der selbe Fehler.

    Hier der letzte Auszug:
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:19:“Plugin-Version: 1.7″;s:9:“log_level“;s:5:“debug“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:123:“Importverzeichnis: /homepages/36/d578175001/htdocs/backends/immobilienpartner-pb/wp-content/uploads/immonex-openimmo-import“;s:9:“log_level“;s:5:“debug“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:131:“Archivverzeichnis: /homepages/36/d578175001/htdocs/backends/immobilienpartner-pb/wp-content/uploads/immonex-openimmo-import/archive“;s:9:“log_level“;s:5:“debug“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:41:“Entpacke openimmo_120151105_145529_50.zip“;s:9:“log_level“;s:4:“info“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:54:“Erfolgreich entpackt: openimmo_120151105_145529_50.zip“;s:9:“log_level“;s:5:“debug“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:34:“Max. Script-Ausführungszeit: 30 s“;s:9:“log_level“;s:5:“debug“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:40:“Max. Script-Speicherverbrauch: 122880 kb“;s:9:“log_level“;s:5:“debug“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:50:“Max. Anzahl Datensätze pro Scriptlauf: unbegrenzt“;s:9:“log_level“;s:5:“debug“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:65:“Max. Anzahl zu löschender Datensätze pro Scriptlauf: unbegrenzt“;s:9:“log_level“;s:5:“debug“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:52:“Max. Anzahl Dateianhänge pro Scriptlauf: unbegrenzt“;s:9:“log_level“;s:5:“debug“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:23:“1 XML-Dateien im Archiv“;s:9:“log_level“;s:5:“debug“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:52:“XML-Datei wird verarbeitet: data_20151105_145529.xml“;s:9:“log_level“;s:4:“info“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:29:“Immobilien in dieser Datei: 1″;s:9:“log_level“;s:5:“debug“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:18:“Umfang: Teilimport“;s:9:“log_level“;s:4:“info“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:39:“Anbieter: Georg Knaup – Ihr Immopartner“;s:9:“log_level“;s:4:“info“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:21:“OpenImmo ANID: 110000″;s:9:“log_level“;s:4:“info“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:2:“–„;s:9:“log_level“;s:1:“*“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:54:“Immobilie 1 von 1: Wohnen in der Südstadt – Erstbezug“;s:9:“log_level“;s:4:“info“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:36:“OpenImmo OBID: MOA001-38461100003617″;s:9:“log_level“;s:5:“debug“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:25:“Aktion: Neu/Aktualisieren“;s:9:“log_level“;s:4:“info“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:68:“Immobilie nicht anhand OpenImmo-OBID gefunden: MOA001-38461100003617″;s:9:“log_level“;s:5:“debug“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:55:“Immobilien-Datensatz-Erstellungsdatum (XML): 2015-11-05″;s:9:“log_level“;s:5:“debug“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:25:“Sprache der Immobilie: de“;s:9:“log_level“;s:5:“debug“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:33:“Immobilie erstellt, Post-ID: 5472″;s:9:“log_level“;s:5:“debug“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:57:“Immobilienadresse NICHT zur Veröffentlichung freigegeben“;s:9:“log_level“;s:5:“debug“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:52:“Geo-Koordinaten der Immobilie: 51.7113515, 8.7542577″;s:9:“log_level“;s:5:“debug“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:27:“Ãœbersetzungs-ID (DE): 3617″;s:9:“log_level“;s:5:“debug“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:17:“Anhang: 3617B.JPG“;s:9:“log_level“;s:5:“debug“;}
    a:3:{s:9:“timestamp“;i:1446824463;s:7:“message“;s:144:“Anhang-URL: http://appkreativ.de/backends/immobilienpartner-pb/wp-content/uploads/immonex-openimmo-import/openimmo_120151105_145529_50/3617B.JPG“;s:9:“log_level“;s:5:“debug“;}

    #3553
    Carsten Scheuer
    Verwalter

    Es ist möglich, dass hier beim Skalieren des Bildanhangs der Speicher ausgeht o. ä. (Die betr. Datei ist mit knapp 3 MB auch recht groß.)

    Bitte testen Sie mal Folgendes: Rufen Sie die Plugin-Konfigurationsseite im WP-Backend auf und laden Sie die Seite anschließend erneut, nachdem Sie die folgenden Parameter an die URL angehangen haben:

    &action=import&force_resumption=1

    Nun sollte die PHP-Fehlermeldung ausgegeben werden, die den Scriptabbruch verursacht (ggfls. muss noch temporär die Konstante WP_DEBUG in der wp-config.php auf true gesetzt werden).

    Bitte posten Sie Meldung anschließend in diesem Thread. Danke!

    #3559
    Willy Braun
    Teilnehmer

    Die von Ihnen genannten Maßnahmen haben nicht wirklich das Problem aufzeigen können.
    Das Aktivieren von WP_Debug hat auf jeder Page folgendes gelistet:
    Notice: Die verwendete Konstruktoren-Methode für WP_Widget ist seit Version 4.3.0 veraltet! Verwende stattdessen
    __construct()
    . in /homepages/36/d578175001/htdocs/backends/immobilienpartner-pb/wp-includes/functions.php on line 3457

    Notice: Die verwendete Konstruktoren-Methode für WP_Widget ist seit Version 4.3.0 veraltet! Verwende stattdessen
    __construct()
    . in /homepages/36/d578175001/htdocs/backends/immobilienpartner-pb/wp-includes/functions.php on line 3457

    Notice: Die verwendete Konstruktoren-Methode für WP_Widget ist seit Version 4.3.0 veraltet! Verwende stattdessen
    __construct()
    . in /homepages/36/d578175001/htdocs/backends/immobilienpartner-pb/wp-includes/functions.php on line 3457

    Notice: Die verwendete Konstruktoren-Methode für WP_Widget ist seit Version 4.3.0 veraltet! Verwende stattdessen
    __construct()
    . in /homepages/36/d578175001/htdocs/backends/immobilienpartner-pb/wp-includes/functions.php on line 3457

    Notice: Die verwendete Konstruktoren-Methode für WP_Widget ist seit Version 4.3.0 veraltet! Verwende stattdessen
    __construct()
    . in /homepages/36/d578175001/htdocs/backends/immobilienpartner-pb/wp-includes/functions.php on line 3457

    Notice: Die verwendete Konstruktoren-Methode für WP_Widget ist seit Version 4.3.0 veraltet! Verwende stattdessen
    __construct()
    . in /homepages/36/d578175001/htdocs/backends/immobilienpartner-pb/wp-includes/functions.php on line 3457

    Warning: session_start(): Cannot send session cache limiter – headers already sent (output started at /homepages/36/d578175001/htdocs/backends/immobilienpartner-pb/wp-includes/functions.php:3457) in /homepages/36/d578175001/htdocs/backends/immobilienpartner-pb/wp-includes/plugin.php on line 503

    Das Aufrufen des Imports hat auch nur die oben erwähnten Zeilen gelistet ohne Aufschluss über den Import zu geben. Die Log hat gezeigt das er nach jedem Bild versucht hat den Import weiter durchzuziehen. Ich denke dafür war das force_resumption verantwortlich.

    Letztendlich habe ich die Bilder manuell mal verkleinert (von z.B. 2,7mb auf 900kb) und siehe da der Import läuft sauber durch.

    Nun ist die Frage wie ich den Fehler umgehen kann – also das auch größere Bilddateien funktionieren und nicht zu einem Fehler führen?! Den genauen Fehler konnte ich ja nicht ermittelt. Die Webseite wird bei 1&1 gehostet. Keine Ahnung ob es da Probleme mit der PHP Konfiguration gibt.

    Können Sie mir da weiterhelfen oder einen Tipp geben?

    Freundliche Grüße,
    Willy Braun

    #3560
    Willy Braun
    Teilnehmer

    Zusätzlich stellt sich mir die Frage, wie PDFs verarbeitet werden und wie ich sie ebenfalls zu der Immobilie anzeigen kann (Grundrisse u.s.w.).

    Können Sie mich da aufklären? In der Log werden sie ja beachtet, aber ich sehe die PDFs nicht in der Immobilienansicht auf der Seite

    #3561
    Willy Braun
    Teilnehmer

    Ich hab die Widgets in der Doku gefunden, von daher erübrigt sich die vorherige Frage.

    #3562
    Carsten Scheuer
    Verwalter

    Hallo Herr Braun,

    wenn gar keine Fehlermeldung angezeigt wird heißt das meistens, dass das Importscript durch einen internen Serverfehler abgebrochen wurde – d. h. ohne Möglichkeit, den Fehler abzufangen. Hinweise zur Ursache (meistens Timeout oder nicht genügend Hauptspeicher) hierzu finden Sie im Regelfall in den Server-Logdateien des Webspaces, falls Sie hierauf Zugriff haben.

    Die Meldung bzgl. der veralteten Konstruktoren-Methode kommt vom WordPress-System selbst, die können Sie ignorieren.

    In Ihrem Fall hängt das Problem ja offensichtlich mit den großen Bilddateien zusammen. Könnten Sie mal testweise versuchen, eine solche Datei ganz normal in der Mediathek hochzuladen? (Der Importer verwendet die gleichen internen WP-Uploadfunktionen.)

    Falls der Fehler nur sporadisch oder bei einzelnen Dateien auftritt, kann man ihn durch das Hinterlegen einer 1 im Feld „Max. Anzahl Dateianhänge“ im Tag „Script-Ressourcen“ umgehen. (Kann eine Bilddatei auch im dritten Anlauf nicht importiert werden, wird sie übersprungen.)

    Hilft diese Maßnahme nichts bzw. ist auch ein Upload via Mediathek nicht möglich, müssen entweder die Bilder vor der Übertragung verkleinert oder das Hostingpaket upgegradet werden (mehr Speicher/Laufzeit).

    #3639
    Willy Braun
    Teilnehmer

    Hallo Herr Scheuer,
    ich bin mittlerweile einiges ausprobiert und bin zu keiner zufriedenstellenden Lösung gekommen. Unser Kunde war vorher bei 1&1 und hatte Joomla mit dem Jimmo Plugin keine Probleme mit der Größe der Bilder.
    Nun haben wir die Webseite auf WordPress migriert und Ihr Plugin eingesetzt.
    Wir haben nun das Hostingpaket auf 1&1 Unlimited Plus geupgraded, was keine Verbesserung brachte.
    Testweise haben wir die Website auf einen Rootserver mit 8 CPU Kernen und 16GB Ram kopiert, wo der Import dann endlich geklappt hat.
    Es ist schwer dem Kunden zu vermitteln das er jetzt für die neue Webseite einen 40-50€/Monat Rootserver benötigt, damit 3MB Bilddateien bearbeitet werden können – vor allem weil es ja vorher bei Joomla ging.

    Gibt es da noch irgendeine Möglichkeit verbessertes Debugging zu bekommen oder die Bildkonvertierung vom Speicherverbrauch zu optimieren?

    Beste Grüße,
    Willy Braun

    #3640
    Carsten Scheuer
    Verwalter

    Das WordPress-Grundsystem an sich benötigt zwar schon relativ viel Hauptspeicher (ca. 32 MB), trotzdem sollte das Unlimited-Plus-Paket bei 1&1 normalerweise ausreichend sein. (Wenn beim Skalieren von Bildern der Speicher ausgeht liegt das übrigens mehr an den Bilddimensionen als an der Dateigröße.)

    Laut meiner gerade durchgeführten Recherche liegt das maximale Script-Speicherlimit hier bei 128 MB, wobei standardmäßig nur 90 MB eingestellt sind.

    Bitte legen Sie zur Einstellung des Maximal-Limits einmal testweise eine Datei php.ini mit folgendem Inhalt im WordPress-Hauptverzeichnis an:

    memory_limit=128M

    (Weitere Infos hierzu: http://bit.ly/1MvAdW2)

    Testen Sie anschließend den Upload der betr. Bilddatei zunächst über die Mediathek.

    Wenn’s mit der Erhöhung des Memory-Limits immer noch nicht funktionieren sollte, wäre ein Blick in die Server-Log-Dateien hilfreich. (Vielleicht liegt ja auch ein ganz anderer Fehler vor.)

10 Beiträge anzeigen - 1 bis 10 (von insgesamt 10)
  • Du musst angemeldet sein, um zu diesem Thema eine Antwort verfassen zu können.