Imports show @en, @es or @de in slug names

Real estate plugins for your WordPress site Forums immonex OpenImmo2wpCasa (English) Imports show @en, @es or @de in slug names

This topic contains 7 replies, has 2 voices, and was last updated by  Carsten Scheuer 2 years, 5 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #5912

    rodemann
    Participant

    Hi,

    Since a while we notice that all imports show a @en or the language relevant version show up in the Slug name for locations and features.
    How can we easily get rid of this showing up?

    Best Regards
    Michael

    #5913

    Carsten Scheuer
    Keymaster

    Hi Michael,

    adding language tags to all slugs was the default behaviour in OpenImmo2wpCasa versions prior to 2.0. In theory, it would be possible to disable this by a filter function (return false in a function hooked to immonex_oi2wpc_enable_multilang), but that would lead to trouble in multilingual sites.

    Since 2.0, the tags are only added if a term with the same title already exists. So the solution for this issue is updating the plugin to the current version (if not already installed) and manually changing the existing slugs.

    #5921

    rodemann
    Participant

    Hi Carsten,

    Updating was not a option due to an earlier issue we had (See here: https://plugins.inveris.de/forums/topic/property-types-slug-issue/). Is there some change in future updates which allow us to use the new version now?

    Best Regards
    Michael

    #5922

    Carsten Scheuer
    Keymaster

    Sorry, I didn’t remember the previous issue!

    If I see it correctly, one problem is that the language tags (@en, @de…) for some taxonomy terms are displayed in the frontend. This can be prevented by adding this filter functions to wpcasa-functions.php or the child theme’s functions.php:

    Concerning future updates, we would have to implement a kind of flag for switching back to the previous slug creation/recognitions behaviour. I’ll investigate if this is possible without too much effort.

    #5923

    rodemann
    Participant

    Hi Carsten,

    Thank you for this update.

    I tried the filter function but without success. Once this function is active the whole website is white and most likely returns some PHP errors.

    (Error from log: PHP Parse error: syntax error, unexpected ’20’ (T_LNUMBER) in ../themes/penthouse/functions.php on line 916, referer: http://www.***.com/***.php?page=mlang&tab=strings&s&group=-1&paged=1

    Could it be the # tag is misinterpreted?

    In regards to future updates of your module and the multilingual module i would love to be able to make use of the latest versions. I hope it is not to much work to have this feature implemented.

    Best Regards
    Michael

    #5929

    Carsten Scheuer
    Keymaster

    Hello Michael,

    it seems we had a little problem with the code syntax highlighter – some entities had been converted which led to invalid code.

    Please copy and insert the code snippet again.

    #5930

    rodemann
    Participant

    Hi Carsten,

    Thank you for your quick response. This indeed does the trick now and removes the @.. attachment from the name.

    Best Regards
    Michael

    #6474

    Carsten Scheuer
    Keymaster

    Although this thread is already some months old, here comes a quick update on this topic:

    We’ve released a new version of immonex OpenImmo2wpCasa today which includes a hook for switching back to the “classic” behaviour concerning taxonomy term slugs: With the following filter function, adding the language codes on term creation can be made obligatory again.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.