Ken Burns Animation ist nach Update auf Version 4.8.8 „verschwunden“

Immobilien-Plugins für Ihre WordPress-Website Foren immonex OpenImmo2WP Ken Burns Animation ist nach Update auf Version 4.8.8 „verschwunden“

4 Beiträge anzeigen - 1 bis 4 (von insgesamt 4)
  • Autor
    Beiträge
  • #17547
    Monika Balint
    Teilnehmer

    Guten Morgen,
    nach dem Update von openImmo2WP am 15. April werden neu geladene Immobilien plötzlich ohne die im Kickstart-Theme zuerst verwendete Ken-Burns Animation angezeigt.
    So sollte es aussehen:
    https://www.balint-immobilien.at/immobilie/2-fuer-1-grosszuegige-vollmoeblierte-gartenwohnung-im-zentrum-von-velden-am-woerthersee/
    Und so sieht es jetzt bei allen neuen Immobilien aus:
    https://www.balint-immobilien.at/immobilie/ideale-anlage-lichtdurchflutete-sehr-gepflegte-4-zi-wohnung-in-zentrale-lage-in-klagenfurt/

    Beim Einwarten der beiden Immos ist kein Unterschied gemacht worden.
    Im Quelltext ist folgendes zu sehen. Anstatt wie davor hier die Animation zu übergeben:
    div.inx-gallery__image.uk-inline.uk-position-cover.uk-animation-kenburns.uk-animation-reverse.uk-transform-origin-center-left
    wird bei den Bilder nur folgendes übergeben:
    div.inx-gallery__image.uk-inline.uk-position-cover

    Eine weitere Frage, die sich uns ins diesem Zusammenhang noch stellt, ist ob es möglich ist eine automatische Animation aller Objektbilder anzustarten?

    Vielen Dank für die Hilfe,
    Richard

    #17563
    Carsten Scheuer
    Verwalter

    Hallo Richard,

    zunächst mal sorry für die verspätete Antwort! Dass der Ken-Burns-Effekt bei den neuen Objekten nicht aktiviert wird hat nicht direkt mit dem OpenImmo2WP-Update zu tun, sondern mit einer hierfür definierten Maximalhöhe der Fotos. Diese ist aktuell noch fix in der betr. Template-Datei hinterlegt und sollte daher auch dort geändert werden. (Die Möglichkeit der Anpassung per Filter-Hook haben wir bereits auf unserer To-Do-Liste…)

    Die angepasste Version der Template-Datei wird im Child-Theme-Ordner gespeichert – hier kann übrigens auch die gewünschte Autoplay-Funktion aktiviert werden. Die Vorgehensweise sieht wie folgt aus:

    1. Unterordner immonex-kickstart/default/single-property im Child-Theme-Verzeichnis anlegen

    2. Template-Datei …/wp-content/plugins/immonex-kickstart/skins/default/single-property/gallery.php in den neu angelegten Skin-Ordner kopieren

    3. Wert der Konstante INX_SKIN_MAX_IMAGE_HEIGHT in der kopierten Datei erhöhen (z. B. 1000):

    4. „autoplay: true“ im Attribut uk-slideshow des DIV-Elements mit der Klasse inx-gallery__image-slide ergänzen:

    Bei Bedarf können auch noch weitere Slider-Parameter hinzugefügt werden (bspw. „autoplay-interval: 7000“ für die Anzahl der Millisekunden bis zum nächsten automatischen Bildwechsel; alle Optionen in der UIkit-Dokumentation)

    #17760
    Monika Balint
    Teilnehmer

    Hallo Carsten,

    kein Thema. War ja nicht „lebensnotwendig“ …

    Bestens. Ich hab das so lösen können. Allerdings leider nicht mit dem Child-Theme. Das hat nicht funktioniert.

    Ich verwende das „Hello Elementor“ Theme. Da habe ich ein Child Theme. In dem hab ich die von dir erwähnten Ordner angelegt, 2x kontrolliert und dann die gallery.php modifiziert. Wenn ich sie im originalen Plugin-Ordner von immonex-kickstart verwende funktioniert es, die Einstellungen im WordPress Child Theme werden leider nicht verwendet…

    Hast du da noch einen Tipp für mich?

    Danke,
    Richard

    #17762
    Carsten Scheuer
    Verwalter

    Hallo Richard,

    Ordner/Name der modifizierten Galerie-Template-Datei ist ganz sicher .../wp-content/themes/CHILD-THEME-NAME/immonex-kickstart/default/single-property/gallery.php und im WP-Backend ist unter immonex > Einstellungen das Standard-Skin (Quiwi) ausgewählt?

    Unter immonex.dev ist seit heute übrigens auch noch eine neue Beta-Version von Kickstart verfügbar, bei der u. a. auch das Galerie-Template leicht angepasst wurde. Das vorhandene Plugin durch die neue Version zu ersetzen, wäre auch noch einen Versucht wert. (In diesem Fall sollte auch die Datei gallery.php im Child-Theme-Ordner durch die aktualisierte Variante ersetzt werden.)

4 Beiträge anzeigen - 1 bis 4 (von insgesamt 4)
  • Du musst angemeldet sein, um zu diesem Thema eine Antwort verfassen zu können.